Serial Error writing

0
0

Hello,

I’ve pulled up an older bomebox patch (which has been working fine for some time) and although I can get it working on the bomebox itself, I can’t get it to send serial data from midi translator on the computer in order to test and modify the patch:
I’m getting:
OUT 1.34 Error: cannot write: ‘[serial string]’ to /dev/cu.usbserial-FT0NL3ZO [alias]

No lights come on at the USB- serial interface

I’ve run lsof | grep usbserial in the command line and it’s said that midi translator is using the USB-Serial device (FTDI USB-RS422) and have re-installed drivers (although it’s being seen by midi translator).  Running OSX 10.14.4

Can you help, please?

 

Marked as spam
Posted by (Q&A Forum: 3, Answers: 8)
May 13, 2019 7:16 pm
10 views
0
Private answer

Thanks Steve,  Midi translator seems to be seeing the correct device name (same as when I look for USB serial devices in the command line), it’s appearing as ‘open’ and I can get it to output commands in a serial monitor program (not open at the same time)

Marked as spam
Posted by (Q&A Forum: 3, Answers: 8)
May 13, 2019 8:25 pm
Indeed, you cannot open the same serial port on the same machine with two different applications. You will need to connect up another serial device to the cable with a monitor and look at the output from there. For me, I use a Chromebook with a serial monitor running Beagleterm and it’s own serial cable (with a null modem adapter). Alternatively if there is an application creates virtual serial loopback ports, you can use that. I’m not aware of anything on Mac but I have something on Windows that does that so it allows me to test serial port functionality without actually having any real serial ports.
( at May 13, 2019 10:45 pm)
0
Private answer

Hi, both Windows and Mac are notorious for reassigning device names to their serial ports.  Please go into settings serial ports and experiment with other serial ports that your Mac thinks it has and then try again. Remember also in you project to always communicate with the serial port alias you assigned.  I also have OS 10.14.4 and have experienced no problems (except random port reassignment) with serial ports.

 

 

Marked as spam
Posted by (Q&A Forum: 38, Answers: 3209)
May 13, 2019 7:35 pm