Photoshop, Beatstep, Actions and Function keys on Macintosh

0
0

Hi and thanks in advance for any help.

I am using an Arturia Beatstep to control Photoshop via Midi Translator Pro and all has been going fine until I tried to get a pad to trigger an action which must use a Function key. I get an error message which says the action is already playing. This means the keystroke is being sent twice.

I have had no trouble until I have tried to use the F keys, everything else works fine.

Settings in the MIDI Control Centre are for Key 11, Mode: Switched Control, Option: Gate, Channel: 1, CC Number 47, Off Value: 0 and On Value: 1

The setup in the Translator is Control Change on ch. 1 with CC#:47 (0x2F) and any value. I have set both Physical Keys and text as the Outgoing Value and got the same result. I have added a 1 second delay, same result.

The Action plays correctly from both the keyboard and a Wacom Tablet button. I can recreate the problem by playing the Action twice in quick succession hence my belief that 2 commands are being sent.

Thanks again for any assistance,

Terry

 

 

Attachments:
Marked as spam
Posted by (Q&A Forum: 1, Answers: 1)
November 28, 2017 12:31 am
21 views
0
Private answer

Hi, since the on condition is 1 and the off condition is zero, instead of setting the translator for any value, just set it to a value of one. What I believe is happening is that the Function key is being triggered upon both press and release of the controller. Having it only trigger on press (or release) should fix the problem.  Let me know if this helps.

Steve

bome@sniz.biz

Independent Bome Programming Specialist

Bome Q&A moderator

 

Marked as spam
Posted by (Q&A Forum: 22, Answers: 1142)
November 28, 2017 1:11 am

Hi Steve,

Thanks very much, problem solved.

Terry

( at November 28, 2017 1:40 am)

My pleasure! Been there, done that.

( at November 28, 2017 1:41 am)