This forum is read-only. Please post new topics in our Q&A forum.

What have I done wrong??

General discussion about using Restorator.

Moderator: florian

Locked
RBCC
Power User
Posts: 20
Joined: Sun Jan 25, 2009 4:37 am

What have I done wrong??

Post by RBCC » Sun Jul 26, 2009 8:08 pm

Code: Select all

 CONTROL "", 110, 1033, "STATIC", SS_BITMAP | WS_CHILD | WS_VISIBLE | WS_GROUP, 1, 48, 349, 158 
What have I done wrong?
[/code]

User avatar
florian
Bome Software: Founder
Posts: 2435
Joined: Thu Apr 28, 2005 10:09 pm
Location: Munich, Germany
Contact:

Post by florian » Mon Jul 27, 2009 1:40 pm

how about

Code: Select all

CONTROL 110, 1033, "STATIC", SS_BITMAP | WS_CHILD | WS_VISIBLE | WS_GROUP, 1, 48, 349, 158 
or

Code: Select all

CONTROL "", 1033, "STATIC", SS_BITMAP | WS_CHILD | WS_VISIBLE | WS_GROUP, 1, 48, 349, 158 
?
Florian

RBCC
Power User
Posts: 20
Joined: Sun Jan 25, 2009 4:37 am

Does this work the same for avis?

Post by RBCC » Tue Jul 28, 2009 2:48 am

Does this work the same for avis in dialogs? John

RBCC
Power User
Posts: 20
Joined: Sun Jan 25, 2009 4:37 am

I get this

Post by RBCC » Tue Jul 28, 2009 5:46 am

CONTROL 110, 1033, "STATIC", SS_BITMAP | WS_GROUP, 1, 48, 349, 158, 0x010000
Line 6 : I can't find style flags!

What does that mean? :D

User avatar
florian
Bome Software: Founder
Posts: 2435
Joined: Thu Apr 28, 2005 10:09 pm
Location: Munich, Germany
Contact:

Post by florian » Fri Jul 31, 2009 2:04 pm

This works fine for me:

Code: Select all

1 DIALOG 0, 0, 252, 218
STYLE DS_SETFONT | DS_MODALFRAME | DS_FIXEDSYS | WS_POPUPWINDOW | WS_VISIBLE | WS_CAPTION
CAPTION "Test"
FONT 8, "MS Shell Dlg"
{
CONTROL 110, 1033, "STATIC", SS_BITMAP | WS_GROUP, 1, 48, 349, 158, 0x010000
}
Provided that there is a Bitmap resource named 110.

Please copy/paste the entire RC code here so that I can see what's happening.

Regards,
Florian

Locked