This forum is read-only. Please post new topics in our Q&A forum.

Crazy Error Messages

General discussion about Bome's Mouse Keyboard

Moderator: florian

Locked
xodusthess
New User
Posts: 2
Joined: Fri Nov 03, 2006 11:05 pm

Crazy Error Messages

Post by xodusthess » Mon Nov 06, 2006 3:41 pm

Everytime I try using this with Cuase SX I get error messages. It says that Port 1 is being disabled because MIDI feedback has been detected. What's that all about? I follow the tutorial on setting the keyboard to work with Cubase, but as soon as I touch one button, it's like all hell breaks loose and I have to start all over with the whole process, but I can never get to the place where I can hear a sound. Anyone care to enlighten me?

Thanks in advance
X

User avatar
florian
Bome Software: Founder
Posts: 2435
Joined: Thu Apr 28, 2005 10:09 pm
Location: Munich, Germany
Contact:

Post by florian » Mon Nov 06, 2006 11:14 pm

Hi, this doesn't sound good, but probably it's fairly easy to solve. With virtual MIDI ports, it's easy to create feedback loops: if the program (e.g. Cubase) repeats all MIDI messages to, say, Yoke 1, but it also receives messages on Yoke 1, then it'll receive the same messages that it sends, infinitely. Since this happens very fast, it'll likely block your computer because it's busy sending and receiving the same message over and over again.

Now, Cubase seems to notice such a feedback and issue such an error message. The tricky part is to find the setting in Cubase to prevent the feedback.

Some places to check:
- turn off Midi Thru in Cubase
- unselect Yoke 1 as MIDI Out (or any Yoke's as MIDI out)
- ...

Hope that works! Tell us if you found a solution.

Regards,
Florian

xodusthess
New User
Posts: 2
Joined: Fri Nov 03, 2006 11:05 pm

Thanks but still help me out....

Post by xodusthess » Tue Nov 07, 2006 3:54 pm

Thanks for the response. Ok here's what I did so far, so tell me where I am going wrong....

I am currently in Device Setup:

All MIDI Inpits are marked Yes for active beside MIDI Yoke NT

Default MIDI ports, what should be there:
MIDI has ALL MIDI Inputs
MIDI Out is now showing Microsoft MIDI Mapper insteak of MIDI Yoke, is it safe to leave it like that? (I can tell you, the answer is No. I just tried playing a note and the same error crash took place) So what should my setup in the Device Set-up look like?

In Direct Music:
All of the MIDI Yoke NT's on the Out portion are showing No for active but for In, all of them say Yes (Emulated).

Last but not least, how do I turn off MIDI Thru in Cubase? Where do I find that?

Thanks for all your assistance.
At the

User avatar
florian
Bome Software: Founder
Posts: 2435
Joined: Thu Apr 28, 2005 10:09 pm
Location: Munich, Germany
Contact:

Post by florian » Tue Nov 07, 2006 10:50 pm

Hi,

it's possible that the MIDI Mapper is one of the MIDI Yokes, so you'd rather turn that off, too.

Currently, I don't have Cubase installed, I'm not sure how and where you'd find a Midi Thru option. Try to isolate all outgoing MIDI messages...

Regards,
Florian

PS: you may have better luck in a Cubase forum, since this is really an issue independent of Mouse Keyboard, I guess.

Locked