Page 1 of 1

How Can I Reduce Latency?

Posted: Thu Feb 05, 2009 4:46 am
by Alec
Great piece of kit :) ; seems to snap into Reason 4 pretty easily.

However, latency of about 250ms is severely affecting performance.
(Key press to audio signal = 250 miliseconds.) :|

Isolating the problem:
1 - Tried changing latency settings in Reason down to 5ms (min), but no discernible effect.
2 - Reinstalled and checked again this time with BMK as standalone; NOT patched to Reason; no MIDI Port Driver (uninstalled), and latency is the same; still 250ms. I press a key, and a quarter of a second later I get a reaction (note-on) from BMK. So it seems my latency problem is with BMK, not Reason. Anyone know how I can reduce the latency?

Definitely up for paying the (miniscule!) license fee if I get the latency issue sorted!

If it helps:
Compaq V3700 (SCSI hard drive on this model), WinXP Pro SP2, [also LoopBe1, Reason 4.0; but latency issue is present independent of these applications].

The silence is deafening

Posted: Thu Feb 05, 2009 6:43 pm
by Alec
Let's be clear:
:shock: If this is a performance-capable tool, then we should be able to get latency levels of significantly less than 100ms (from my experience, 30ms wouldn't be a big deal). Otherwise, it's just a toy. For what it's worth, I've been working with these sort of HW and SW issues for 15 years with Cubase (from Atari ST to PC), Cakewalk, Reason and others . I'm not a natural skeptic re BMK (I like the idea; pretty enthusiastic re the execution - besides this latency issue); neither am I unfamiliar with the trad approaches to solving latency issues ('optimise PC; cancel unnecessary services, etc').

But this is... without a solution to the problem I've outlined... weak, dude.

FWIW: I have decent response time from external MIDI hardware, but not from BMK.

So: Any advice?

Alec

Posted: Wed Feb 18, 2009 6:55 pm
by florian
Hi Alec,

Mouse Keyboard is not adding or creating any significant delays (or latency). It's overall delay should be less than 1 millisecond. You can try that by selecting a hardware MIDI synthesizer in the MIDI OUT menu.

I would guess that all latency that you experience is due to the settings in Reason or your soundcard, or maybe even due to the virtual MIDI driver used.

Do you use ASIO with Reason? that usually fixes issues. Which soundcard do you use?

Thanks,
Florian