This forum is read-only. Please post new topics in our Q&A forum.

notes sometimes have zero duration

General discussion about MIDI Translator

Moderators: florian, DvlsAdvct

Post Reply
bosco adama
New User
Posts: 4
Joined: Fri Jan 05, 2007 6:35 pm

notes sometimes have zero duration

Post by bosco adama » Fri Jan 05, 2007 6:44 pm

I've been trying out the MidiTranslator for changing cc 7 volume to cc 11 expression. The translation of the controllers works good but I get a zero duration on some notes.

my settings -

incoming B0 07 vv
outgoing B0 0B vv

any suggestions?

User avatar
florian
Bome Software: Founder
Posts: 2435
Joined: Thu Apr 28, 2005 10:09 pm
Location: Munich, Germany
Contact:

Post by florian » Sun Jan 07, 2007 9:04 pm

Your conversion scheme is correct, so I wonder what the problem with the zero duration notes can be? can you try if they still appear if you disable the Translator entry in MT, but leave MT "in the loop"?

Thanks,
Florian

bosco adama
New User
Posts: 4
Joined: Fri Jan 05, 2007 6:35 pm

Post by bosco adama » Thu Jan 11, 2007 6:16 pm

I've used MT without a translator entry and still get quite a few zero durations. Very puzzling.

Studiologic SL880 keyboard
Midisport 8x8 isb interface
WinXP
MidiTranslator
Sonar 4.3
Garritan Strad and GPO vst instruments.

I'm just trying to convert the cc# pre sonar to control the vsti.
I'll keep experimenting and post the results.

Bosco

admin
Site Admin
Posts: 25
Joined: Thu Apr 28, 2005 9:46 pm

Post by admin » Thu Jan 11, 2007 7:15 pm

ah OK, that's what I was expecting, sort of. At least, MT's Translator processing is not faulty...

Are you using Midi Yoke or so to transfer MT's MIDI to Sonar? Maybe it's worth a try with a different virtual MIDI driver? a list is here in the second paragraph:
http://www.bome.com/midi/keyboard/help/rsn3_tut.php

Regards,
Florian

bosco adama
New User
Posts: 4
Joined: Fri Jan 05, 2007 6:35 pm

Post by bosco adama » Fri Jan 12, 2007 10:23 pm

I installed and set up Maple virtual midi. The same results - many notes w/ zero duration... :?

User avatar
florian
Bome Software: Founder
Posts: 2435
Joined: Thu Apr 28, 2005 10:09 pm
Location: Munich, Germany
Contact:

Post by florian » Mon Jan 15, 2007 11:38 am

I'm lost now! this has never been reported, in almost 10 years of Midi Translator! Maybe you can ask other users of your MIDI device, in forums specific to it, or the manufacturer?

Or someone else will help in this forum.

THanks,
Florian

bosco adama
New User
Posts: 4
Joined: Fri Jan 05, 2007 6:35 pm

Post by bosco adama » Mon Jan 15, 2007 2:56 pm

I am suspecting my studiologic sl 880 keyboarded controller. I've notice other midi anomalies - volume pedals with limited cc7 range.etc...


I'll try another keyboard and post an update.

It's always something! :roll:

thanks

Bosco

Post Reply