Page 1 of 1

Trouble controlling my remote sl

Posted: Thu Jun 12, 2008 1:29 am
by timid
Hello. I wonder if anyone can help..

I'm trying to use bomes with a remote sl in ableton..
I've got a template which works fine with a trigger finger so i know i'm doing something right, but i can't get the remote to work the same way.

For MIDI In i have 'Port 2' selected, but when i select 'capture midi' i get a constant stream of 'F8' appearing.. when i move a fader the code for that fader briefly appears but the constant stream of F8 replaces it.

Any ideas why thats happening, or what i'm doing wrong?

thanks.

Posted: Thu Jun 12, 2008 8:11 am
by florian
Hi, the F8 is the MIDI Clock. You should be able to disable reception by unchecking "MIDI Time Code" in the Options menu.

Does that help?
Florian

Posted: Sun Jun 15, 2008 1:16 am
by timid
ah excellent..

Couldn't find that option in the menu.. i'm using the mac beta, is that why or am i not looking in the right place?

But anyhow, I disabled the midi clock output on the remote as i'm not using it.

Thanks for your prompt response.

Posted: Tue Jul 01, 2008 9:48 am
by florian
Hi,
sorry for the late reply. Indeed, the Mac version does not (yet) allow filtering MTC from the options.

Later,
Florian

Posted: Sun May 03, 2009 11:13 pm
by Rossd
florian wrote:Hi,
sorry for the late reply. Indeed, the Mac version does not (yet) allow filtering MTC from the options.

Later,
Florian
Florin in the PC Pro version 1237, I am unable to find the option to diable the Midi Tme CLock and as such am getting flooded with F8's. Where is the check box hiding?

Thanks,
Ross

Posted: Sun May 10, 2009 5:59 pm
by florian
Indeed, the checkbox is gone, a victim of our effort to simplify MIDI port handling... A way to hack this is the following:

First, make sure the MIDI port you want to use is open, then exit Midi Translator.

On Windows, in the start menu, use the "run" function, and enter "regedit". In that registry editor, go to HKEY_CURRENT_USER\Software\Bome Software\Bome's Midi Translator Pro\MidiTranslator\MIDI.in . On Mac, open .MidiTranslator.bmts in a text editor and locate the [Midi.in] section.

In the list of "nameX" entries, locate the one with the MIDI port that you want to filter F8's. In the corresponding OptionsX entry, you'll most likely see "FTF". These are 3 flags that can either be F for false or T for true. The first one allows (T) or filters (F) Active Sensing messages (FE hex). The second one is for Timing Clock messages (e.g. F8). So by setting the second letter to F, Timing Clock should be removed, e.g.
Options4 -> FFF

On Mac, save the settings file.

Then, start Midi Translator again. Now it should ignore timing clock messages.

Note this is a rather volatile setting. If afterwards you exit Midi Translator when this port is not open, it is likely that it will forget this setting.

We will find a better way in future to enable/disable such filtering.

Note that this is mostly affecting MIDI Capture and the event monitor LED's. Other than that, you can filter such MIDI messages by creating a translator like

Code: Select all

Translator "Remove Timing Clock"
  [x] Stop Processing
INCOMING: F8
  [x] Swallow incoming MIDI message
OUTGOING: [none]
Hope that helps!
Florian

Posted: Tue May 12, 2009 1:08 am
by Rossd
Florian,
Sadly it wont swallow :-( and the registry hack is not an option. Any other ideas?

R

Posted: Fri May 22, 2009 8:10 am
by florian
Hi Rossd,

what's the Log output when you use the "manual" filter?

Thanks,
Florian

Posted: Sat Jun 06, 2009 3:21 am
by simple
I tried the same registry hack and had no luck. When I go back into MT it says "Failed to open Midi device XYZ" for the device I had just hacked.

This really makes the MIDI capture function useless as you can never just key a controller or note and capture the midi details.

Any other ideas to reinstate the midi capture.

Posted: Sat Jun 06, 2009 3:28 am
by simple
I restarted and am now able to get the device open that I hacked. However the F8's are still there for that device, even when I select it as a 'specific port'

Any other suggestions

Posted: Thu Jun 18, 2009 10:14 am
by florian
Hi simple,

one suggestion is to use the log as MIDI capture:
- create a translator like this:
Incoming: MIDI pp qq rr
Outgoing: none
- open View|Log Window

Now you should see all 3-byte MIDI messages in the log.

Sorry... we'll bring back low level filtering in a future version.

Regards,
Florian