This forum is read-only. Please post new topics in our Q&A forum.

Don't output incoming message

General discussion about MIDI Translator

Moderators: florian, DvlsAdvct

Post Reply
danny62
New User
Posts: 1
Joined: Sat Sep 29, 2007 8:52 am

Don't output incoming message

Post by danny62 » Sat Sep 29, 2007 9:03 am

I'd like to use MT with Finale 2008, but I have a problem. When I setup a translator to trigger a keystroke, the incoming message is always output too.
I've "output both translated ...." UNCHECKED but not avail. I notice the same behaviour in Sonar. What's happening?

User avatar
florian
Bome Software: Founder
Posts: 2435
Joined: Thu Apr 28, 2005 10:09 pm
Location: Munich, Germany
Contact:

Post by florian » Tue Oct 02, 2007 7:15 pm

I presume that Options|MIDI Thru is checked, then there are two ways to "swallow" a MIDI message (and prevent it to be output to MT's MIDI OUT):

1) create a specific Translator entry to swallow the MIDI message
In this example, we want the MIDI message 90 40 7F to output a keystroke, and the MIDI message should not be forwarded:

Code: Select all

First Translator entry:
Options/General: Stop Processing: unchecked
Incoming: 90 40 7F
Outgoing: the keystroke

Second Translator entry:
Options/General: Stop Processing: checked
Incoming: 90 40 7F
Outgoing: None
The None outgoing action will take care of swalling the MIDI message. It's important to not check "stop processing" the first translator entry, otherwise the second translator entry will never see the MIDI message and it's going to MIDI thru.

2) Translate the MIDI message to another MIDI message

Code: Select all

Incoming: 90 40 7F
Outgoing: 90 50 7F
Output both incoming and outgoing MIDI message: unchecked
I know you have tried this, but also this solution should really swallow "90 40 7F" and only send "90 50 7F" to MT's MIDI OUT.

Now there may be one reason why Finale/Sonar is still seeing the original MIDI message: some MIDI ports can be opened by several applications at once. Now you must make sure that Finale/Sonar has NOT opened MT's MIDI IN port. Use a virtual MIDI port like Yoke or Maple to connect MT's MIDI OUT to FInale/Sonar's MIDI IN.

Let us know how/if that works.

Regards,
Florian

Post Reply