This forum is read-only. Please post new topics in our Q&A forum.

MIDI controller, Ableton Live, key commands, help please

General discussion about MIDI Translator

Moderators: florian, DvlsAdvct

Post Reply
Kristian
New User
Posts: 2
Joined: Mon Apr 09, 2007 4:42 pm

MIDI controller, Ableton Live, key commands, help please

Post by Kristian » Mon Apr 09, 2007 4:54 pm

I'm trying to set up one of the pads on my Korg Padkontrol to open and close Ableton Live's browser. The key command for this is ctrl+alt+b.

In Bome's, I've set the correct input (I'm sure it's correct, since "capture MIDI worked)

As MIDI Out, I've set MIDI Yoke nt 1 (not sure if this is correct, but it's what seemed most logical)

The pad is sending out a note value with fixed velocity set to 100

In Ableton Live, I've activated all the inputs and outputs available, as my MIDI knowledge is fairly basic/limited

Still, with all of this done, nothing happens. What am I doing wrong?

User avatar
florian
Bome Software: Founder
Posts: 2435
Joined: Thu Apr 28, 2005 10:09 pm
Location: Munich, Germany
Contact:

Post by florian » Wed Apr 11, 2007 10:55 am

Hi Kristian,

I'm not sure you've set it up to the end... What I understand is that you want to emulate "Ctrl+Alt+B" in response to a specific MIDI Note On message. For that, in Midi Translator, you need to add a Translator entry, with

Incoming: MIDI 90 40 64 (or whatever the Padkontrol is sending)
Outgoing: Keystroke Ctrl+Alt+B

You will need to activate Options|Midi Thru in the menu in Midi Translator so that MIDI messages will be routed from MIDI IN to MIDI OUT, i.e. so that they can be passed on to Ableton Live via Yoke. Also, the keystrokes always go to the currently active application, so Ableton Live needs to be active and enabled.

If that still does not work, please describe in more detail
- setup
- expected vs. actual behavior
- what do the MIDI indicators show in MT?

You can also try first with a simplified setup, i.e. change the keystroke to just "B" and try in a text editor like Notepad if that works.

Florian

Kristian
New User
Posts: 2
Joined: Mon Apr 09, 2007 4:42 pm

Post by Kristian » Wed Apr 11, 2007 2:53 pm

Activating midi thru did the trick. Thanks a lot :D This is great!

I had no idea how much more comfortable it would be to click once on a pad rather than ctrl+alt+b over and over again. It's also amazing on ctrl+z and ctrl+y :D Thanks for an awesome program

Post Reply