This forum is read-only. Please post new topics in our Q&A forum.

Using MT and Tranzport to override only certain keys

General discussion about MIDI Translator

Moderators: florian, DvlsAdvct

Post Reply
magog
New User
Posts: 2
Joined: Sun Nov 06, 2005 10:12 pm

Using MT and Tranzport to override only certain keys

Post by magog » Sun Nov 06, 2005 10:26 pm

I'm using Tranzport with Cubase (natvie mode) and I wanted to remap FF and RW, but nothing else. I want everything else on the Tranzport to stay the same.

I made a mapping in MT to intercept Tranzport's FF and RW MIDI messages and send keyboard shortcuts to Cubase. Here's the exported INI file:

Code: Select all

    [TranzCube]
    Name0=Fast Forward
    Incoming0=MID1 90 5C 00
    Outgoing0=KSQ100020BF2BF
    OutputOriginal0=0
    Stop0=1
    Name1=Rewind
    Incoming1=MID1 90 5B 00
    Outgoing1=KSQ100020BE2BE
    OutputOriginal1=0
    Stop1=1
The problem is that now only the FF and RW buttons work in Cubase. All other buttons and knobs on the Tranzport have no effect.

I'm using the following settings:

MIDI IN: Tranzport
MIDI OUT: Tranzport
Midi Thru: enabled

Am I missing something? Is this kind of thing supposed to work?


Michael

User avatar
florian
Bome Software: Founder
Posts: 2435
Joined: Thu Apr 28, 2005 10:09 pm
Location: Munich, Germany
Contact:

Post by florian » Wed Nov 16, 2005 12:31 pm

Hi Michael,

your setup is correct, but incomplete. In order that all other MIDI messages reach Cubase, you need to route them from MT to Cubase using a virtual MIDI port. A quick guide for a virtual MIDI port can be found here:
http://www.bome.com/midi/keyboard/help/cubase_tut.php

Then, select the virtual MIDI port as MIDI OUT in MT and enable the Midi Thru option.

Hope that you'll make it work!
Florian

Post Reply