Page 1 of 1

bulk dump fails

Posted: Mon Nov 10, 2008 10:32 am
by florian
A user reported this:
I use SendSx v1.30 to dump memory on Behringer dsp-8024.

When I dump the memory from DSP, a 1024 bytes block quickly appears and disappears. The log message says that "1024 bytes received successfully" and the real dump start to appears (37465 bytes) and finished successfully. My problem is when I dump this previously saved dump from my dsp8024, it stay in "waiting for dump memory" and staying in that state until I press "cancel" (the only choice that I have). After all, the DSP return in normal mode and I receive a error message like "checksum error-memory cleared". My question: what is that 1024 bytes? How SendSx enable the midi dump?

Posted: Mon Nov 10, 2008 10:35 am
by florian
Hi,

SendSX only detects a bulkdump when the second block of data arrives in rapid succession after the first one. So once the second block arrives, SendSX goes into "receive bulkdump" mode. It clears the first block from display, because it belongs to the bulkdump.

Now for your problem, there are two principal causes:
1) problem of reception
It is unlikely that SendSX receives or stores invalid data. So the only possible cause I can imagine is that SendSX does not receive and store all data -- for whatever reason. Could you find out how many bytes should be in a regular memory dump from the DSP?
Or SendSX receives too many bytes? you can filter to only receive bulk dump data in the settings window: check "only display system exclusive messages in MIDI IN".

2) problem sending
For whatever reason, SendSX may be sending less data than in the .syx file that you saved. That would explain why the DSP stays in wait mode, because it waits until all data arrives. If you found a bulk dump .syx file somewhere else, you could try sending that with SendSX to see if that exposes the same problem.

Now those "whatever reasons" are usually a bad or faulty MIDI driver (how's the DSP connected to your computer?). To smoothen things (hopefully) with bad MIDI drivers, there are two options in SendSX:
1) settings window: send with lower speed, e.g. 557 bytes/s.
2) experiment with different settings of "split long sys ex messages". You need to reload the .syx file after changing that option.

Let me know how that experimenting works.

Thanks,
Florian

Posted: Tue Nov 11, 2008 12:33 am
by florian
the same user replied that he could fix the issue by purchasing a "quality" MIDI adapter, with opto-isolator...

Florian