This forum is read-only. Please post new topics in our Q&A forum.

Problem editing dfm's compiled in C++ Builder 5

General discussion about using Restorator.

Moderator: florian

Locked
firstdegreesystems
New User
Posts: 2
Joined: Wed Oct 11, 2006 4:18 pm

Problem editing dfm's compiled in C++ Builder 5

Post by firstdegreesystems » Wed Oct 11, 2006 4:58 pm

When a form is edited in restorator that either already contains extended characters ie. ASCII code >127 such as a £ sign, or they are added as part of the translation, ie. accented characters common in non-English languages, the form throws an exception when called in the modified executable.
After investigation it was discovered that unmodified strings in the dfm had been converted to a new data type number (20) corresponding to vaUTF8String. This is a new type that was added after version 5 and as such version 5 compiled exe's throw an invalid property type exception as they only handle vaString (6) and vaLString (12).
There needs to be a way to turn off this conversion.

User avatar
florian
Bome Software: Founder
Posts: 2435
Joined: Thu Apr 28, 2005 10:09 pm
Location: Munich, Germany
Contact:

Post by florian » Thu Oct 12, 2006 5:25 pm

Hi,

thanks for the detailed bug report and the analysis. I add this to the TODO list.

Thanks,
Florian

LUIZ HENRIQUE
New User
Posts: 1
Joined: Fri Oct 13, 2006 8:42 pm

Problem editing dfm's compiled in C++

Post by LUIZ HENRIQUE » Fri Oct 13, 2006 8:53 pm

Dear Florian,

I have the same problem!

Please, Do you have some idea when this problem will be fix?

Best regards,

Luiz Henrique
BRAZIL

firstdegreesystems
New User
Posts: 2
Joined: Wed Oct 11, 2006 4:18 pm

Post by firstdegreesystems » Mon Oct 16, 2006 3:28 pm

It also appears that certain blank strings will cause the same problem as well, as per example:-

Title.Text.Strings = (
'')

We too would like this fixed asap

User avatar
florian
Bome Software: Founder
Posts: 2435
Joined: Thu Apr 28, 2005 10:09 pm
Location: Munich, Germany
Contact:

Post by florian » Mon Oct 16, 2006 10:00 pm

we hear you! We're working on a fix.

Regards,
Florian

User avatar
florian
Bome Software: Founder
Posts: 2435
Joined: Thu Apr 28, 2005 10:09 pm
Location: Munich, Germany
Contact:

Post by florian » Tue Oct 17, 2006 4:28 pm

Hi,
this bug is fixed in a private beta version. There is a new option in the settings dialog that lets you save form in compatibility mode (but loosing Unicode capabilities for forms).

If you have purchased Restorator, please contact me directly for access to this beta version: http://www.bome.com/contact.php

The fix will be generally available with Restorator 2007.

Regards,
Florian

Locked