This forum is read-only. Please post new topics in our Q&A forum.

Dialogex problem in restorator 2006

General discussion about using Restorator.

Moderator: florian

Locked
Mikhail
New User
Posts: 2
Joined: Mon Feb 27, 2006 10:47 am

Dialogex problem in restorator 2006

Post by Mikhail » Mon Feb 27, 2006 10:58 am

Restorator 2006 incorrectly saves font styles in DIALOGEX resources. (itallic parameter) . After saving (and reopening) - all signs in dialog becomes itallic.
I see one way to correct it at the moment - return to the restorator 2005 (it works ok ).

User avatar
florian
Bome Software: Founder
Posts: 2435
Joined: Thu Apr 28, 2005 10:09 pm
Location: Munich, Germany
Contact:

Post by florian » Wed Mar 01, 2006 7:23 am

Hi Mikhail,

thanks for reporting this problem, it looks like a rather serious bug. I'll check it out.

Florian

User avatar
florian
Bome Software: Founder
Posts: 2435
Joined: Thu Apr 28, 2005 10:09 pm
Location: Munich, Germany
Contact:

Post by florian » Wed Mar 01, 2006 7:28 am

I could reproduce this bug. It only happens when editing the RC text of the dialog. The graphical dialog editor works as before.

I'm working on a fix and I'll let you know here when an update is available.

Thanks,
Florian

Mikhail
New User
Posts: 2
Joined: Mon Feb 27, 2006 10:47 am

Post by Mikhail » Wed Mar 01, 2006 9:59 am

Hi Florian,
When porting the translation from one app. release to another i need to convert the resources to rc and back ( to see is there any differences in resources between releases).
By the way, could you add a resource comparison feature?
I think it is possible to improove the patcher algorithm to fscan and report the resource differences between two executables.
It would be a very useful feature.

Regards
Mikhail

User avatar
florian
Bome Software: Founder
Posts: 2435
Joined: Thu Apr 28, 2005 10:09 pm
Location: Munich, Germany
Contact:

Post by florian » Wed Mar 01, 2006 11:51 am

I'm working on a translation software with built-in comparison and auto-translation of resources. That would probably solve your needs...

Florian

User avatar
florian
Bome Software: Founder
Posts: 2435
Joined: Thu Apr 28, 2005 10:09 pm
Location: Munich, Germany
Contact:

Post by florian » Wed Mar 01, 2006 1:17 pm

We've posted an Update Patch for Restorator 2006 which fixes this bug. Please download it from http://www.bome.com/Restorator/update.html .

Please report if that fixes the issue.
Thanks,
Florian

Mok
New User
Posts: 1
Joined: Mon May 22, 2006 9:52 am

Post by Mok » Mon May 22, 2006 10:04 am

Not the same problem but similar. When I checked Restorator a few months back it was completely stripping font charset information from DIALOGEX definition. If original resource used something like this:
FONT 10, "Special Font", 0, FALSE, EASTEUROPE_CHARSET
Restorator removed the last parameter completely making the whole definition unusable (as default charset is ANSI). Was it fixed in 2006 edition?

User avatar
florian
Bome Software: Founder
Posts: 2435
Joined: Thu Apr 28, 2005 10:09 pm
Location: Munich, Germany
Contact:

Post by florian » Tue May 23, 2006 11:08 am

Hi Mok,

indeed, Restorator still removes this flag. We weren't aware that you could add a charset setting to the FONT line. This should be added in the next version of Restorator. Please subscribe to the announcement list of Restorator to receive an update email when the feature is ready.

Regards,
Florian

Locked