slow start - Bome Box / Qu-Pac / M-Audio Uno


2016-09-28 06:51:19

The first goal is to control Qu-Pac via midi foot pedal (Lake Butler RFC-1).

1) I have Qu-Pac USB B port connected to BomeBox USB input. The Qu-Pac appears twice on midi ports page, as QU-PAC and as USB 1 (auto-alias).

2) 5-pin DIN midi output on Bomebox feeding M-Audio UNO USB interface direct connected to PC running Midi-Ox for midi datastream monitoring purposes. UNO selected as midi input port on Midi-Ox.

3) 5-pin DIN midi input on Bomebox taking feed from midi foot pedal.

Background info: am having problems with the midi implementation documentation on Qu-Pac. Sending hexcode as defined in A&H documentation not producing desired results on mixer, so I tried monitoring midi output from mixer when performing the desired tasks and discovered discrepancy between what manual suggested and what really worked. As a result, it is very useful to perform edit on mixer, read resulting hexcode in midi-ox monitor, then manually program this code into foot pedal to achieve same result.

I now have this working when feeding Qu-Pac USB directly to PC, but inserting Bomebox into chain and no more signal getting through in any direction. Tried using original default settings on BB (all inputs to all outputs), along with different customized settings (mostly removing unused Network/USB routes for simplicity), but still no love. Midi-Ox not showing reception of any midi data from either Qu-Pac or RFC-1.

All cabling tested and working correctly. Incoming midi indicator LED flashes on receipt of data from foot pedal, but that data not reaching UNO or Qu-Pac.

I get the feeling this may be one of those things where I simply need to turn it all off and walk away for a couple days before trying again and finding instant success...any thoughts?

Bless, Pablo


2016-09-28 07:08:12

courtesy update: BB now passing data from footpedal to UNO and Midi-Ox seeing the data, but Qu-Pac still dead in both directions...but works okay connected directly to PC, bypassing BB...?


2016-09-30 00:24:52

Hi Pablo,
this is strange, we have never observed any problems with the MIDI routing. I assume you have checked back in the MIDI Router? It should show a MIDI route from Qu-Pac (or USB 1) to DIN. Also check the state in the MIDI Devices section. It should be "open" for all concerned ports.
PS: do you have the current firmware 0.9.5?


2016-10-01 01:35:27

Hi Florian,

I really hate being a bother...

Extensive testing (cable swapping, multiple reboots of each device, etc.) reveals that the Qu-Pac is not hot-swapping via USB. Every time I disconnect the USB cable, the midi-over-USB is disabled until I reboot the mixer. Which really sux.

However, with a reboot while connected to BBox it does show two ports OPEN ports for the mixer, Qu-Pac and USB 1 (alias). But still no love on passing midi datastream to or from the DIN ports, which are working okay one with the other.

I have five defined routes: 1) DIN to DIN, 2) DIN to Qu-Pac, 3) DIN to USB 1, 4) Qu-Pac to DIN, and 5) USB 1 to DIN. I have also tried deleting redundant Qu-Pac ports and tested again. No go.

I'm not stressing over this at the moment and have a crazy busy weekend coming up, but wanted to report back while testing results fresh in mind. I won't have a chance to look at this again until next week, and will be trying to speak with A&H people on my side before anything else.

Bless, Pablo


2016-10-01 16:27:08

I've looked a bit into the Qu-Pac's documentation. It appears that the Qu-Pac uses a proprietary USB protocol. While it works out of the box on Mac, a driver is required on Windows. Because Windows does ship with USB class compliant MIDI drivers, my assumption is that the Qu-Pac does not use the USB MIDI class, but a proprietary protocol. So if that assumption turns out to be true, it will not be possible to connect the Qu-Pac to the BomeBox using its USB-B port. Also the Ethernet protocol seems to be A&H proprietary.

Maybe you can ask A&H if they really use a proprietary USB protocol? Because the BomeBox runs Linux inside, if A&H provides a linux driver, that could help...



2016-10-01 23:52:46

if their use of this proprietary protocol prohibits use of BBox I am going to mash my head into a concrete wall...
It's already so stupid that they didn't put a damned DIN port on it...



2016-10-09 00:57:13

it's official: my new BOMEBOX works FLAWLESSLY with EVERYTHING I try connecting it to...except for the A&H QU-PAC. :(:(

We await further word from A&H tech support...could be a while...


2016-10-10 22:55:18

quick update: A&H has been very prompt, and we (Bome) have sent a BomeBox to them for testing.