LPD8 detected but unplugged


2016-09-15 16:32:02

I am having some teething issues with my bomebox. I had attempted to attach a midiman midisport 2x2 Anniversary Edition interface, an akai LPD8, and a midifighter twister, all via a powered USB hub.

From memory, first I tried the midifighter twister on its own, then with the lpd8, and then various combinations of the three. I came to the conclusion from reading about it that I probably have a very bad USB hub, for which I have ordered a replacement. However, the bomebox seems now to exhibit some strange behaviour regarding the midi ports it "sees" and therefore the midi routes available via the WiFi browser interface.

Essentially, it now shows that the "lpd8" is connected, whether or not it actually is, and doesn't make available all of the ports on the 2x2, but instead shows the two separate outs, but only one input. These things still happen even when I unplug the hub, and plug the Midisport 2x2 directly into the bomebox before connecting the power! The midifighter is shown only when connected and with enough power. I cannot rule out the possibility that the Midisport 2x2 will not work properly with the bomebox, although I was pretty sure I had it fully working at one point.
Is there a reason it seems to think the lpd8 is always connected?


2016-09-16 02:04:16

Hmmm, we've never experienced such an issue. As a matter of fact, we've done a lot of tests with the LPD8...
Sometimes, pressing the Pair button can help to resolve intermittent issues. Or, of course, you can try a reboot.
But in principle, what you describe should never happen.
If you can find out anything else, please let us know.


2016-09-16 19:55:01

Hi Florian,

Thanks for all your help. I think that specific problem was to do with my lack of understanding, and also because accidentally pressed the mode switch on the Midisport 2x2! I determined that, when nothing was connected, some (but only some) previous connected items were listed in the ports list, but as "pending". I had not realised it would let me make routes for disconnected devices. I am curious as to why it sometimes seems to list USB ports AND their auto-aliases, and why not all previously connected devices are shown.

I had hoped that buying a D-link dub h7 powered USB, like you sell, would solve the rest of my problems, but so far it has not: now, although at one stage (with the old "very bad" powered hub) my midifighter twister seemed to work properly, it is now performing a power cycle (reboot) whenever I go to adjust a controller on it. This is now the case whether or not I plug it straight into the bomebox (with a 2 Amp supply), or into the D-link hub (regardless of whether it is used in powered or unpowered mode, regardless of what else is plugged in, and regardless of which USB port I use). The midifighter twister is rated 5v 250mA, so I see no obvious reason it should not work where before it did. I am considering doing a factory reset, just in case it magically makes everything work together.


2016-09-19 10:46:58

Hi Monopluralist,
when you unplugged a used device, it will remain as an alias in state pending. Used means that it is either referred to in a route or in a MIDI Translator project (if you have one loaded). When you restart the box, it'll usually remove unused aliases.

Regarding the MF Twister problems, I have no idea what's going on! Does it work when connected to a computer? We have done extensive testing with a MF 3D -- I would think they have very similar MIDI hardware. Maybe you're accidentally sending a Reset message to the twister or a message that it cannot handle?


2016-09-20 17:47:13

Thank you Florian,

This explanation of "used" devices helped me solve my problem!

I had, at some stage, deleted all the auto-mapped (everything to everything else) routes, and re-entered some specific ones manually.

With the MF Twister problem, I am left to assume that the problem existed in my case because the MF Twister was not used in any MTPro projects and had no route already created in the bomebox. The issue resolved itself at the exact moment I created a route and tried again! If only I had realised that having no route set for it would be likely to cause such a problem!


2016-09-22 20:58:46

Hi, glad to hear that! it also means that we can expand on explaining the various states -- at best right in the web config.