Send sx issues


2014-11-16 15:03:18

First time user. I have an alesis SR18. I backed up the midi files using the lastes Bome send SX release. Dumped 1387 lines. Had to do a hard reset on the unit per Alesis. But now i can not restore my files. Send sx is sending usb light flashing, but sr18 is not updating. Cables ( HOSA midi/ usb) appear to work because i send midi notes to the machine and it reacts. But it will not restore the bulk file. Any thoughts as to what im doing wrong?


2014-11-16 16:13:21


please have a look at the new troubleshooting section.


2014-11-19 04:33:03

So I purchased a Yamaha UX16. Down loaded their driver. Same issue. Tried every speed option available. All the same. I even programmed a new pattern in the SR18. Dumped it to the PC. Erased the pattern on the SR18 and tried tor restore it. Nothing.


2014-11-19 10:47:16

That's really strange! It must work somehow! I have used SendSX with an Alesis HR-16 without any problems.

One idea might be to try this on a different computer?
Or a different program (though I don't know any)?



2014-11-20 04:37:44

So this issue is resolved but strangely. The pc i was using was running Windows 7 (64). I moved to another pc running Windows 7 (32). I used a usb drive to bring my original file over. Still nothing. Same old responce ( or should i say lack of). So i tried another small test midi dump. And againt tried to restore. This time the test file worked. Now you have to remember that this is the first time I've tried to dump/ restore the Sr18. No where any where does it tell you that the Sr18 will display a counting of the lines of data as it recieves it and then go into clean up mode. All this time when i tried to restore, the sr18 message said " restore midi" and did not change. So now that I see what's suppose to happen, i went back to my orginal file and tried to restore, nothing happened. SO a Corrupted file...... Crap.........Now i know enough about communication protocols to know that the begiining of a string has to have a start command to tell the other end here i come. I also noticed that the 1st line of both files (test and original) was shorter so, thanks to your program and the midi out window, i copied the 1st line of the test file and overlaid it in place of the 1st line of the orginal file and Bingo....the restore worked......


2014-11-20 13:02:22

wow, good reverse engineering here! and I am very happy that you eventually managed to get it to work AND were able to restore your old settings.

On a side note, I highly doubt that it has anything to do with the one system being 32-bit and the other 64-bit. I'm using SendSX on a 64-bit Windows 7 machine every day and it works without any problems.