(!) Cannot start exe files anymore - fix available


2007-06-26 10:47:47

Every now and then, users report that after installation of Restorator they cannot run any program anymore.

After extensive search we've found the cause of this problem (see below for details).

First, in order to start any program, use the task manager:
Click right on the task bar, select TaskManager, select the "Applications" tab and click "New Task". There, click browse and select e.g. Restorator.exe in "C:\Program Files\Restorator". With this trick you can also start e.g. Internet Explorer from "C:\Program Files\Internet Explorer\IEXPLORE.EXE". Note: batch programs like the fix below will still run with a double-click.

To fix this problem, either start Restorator (see previous paragraph), invoke the menu Tools|Edit File Associations then click Context None and Assoc. None. Press OK, close Restorator, and reboot your computer.

Or, use this batch file (save and then double click it):

Code: Select all

set P="%USERPROFILE%\RemoveRstKeys.reg"
echo REGEDIT4 > %P%
echo [-HKEY_CURRENT_USER\Software\Classes\.exe] >> %P%
echo [-HKEY_CURRENT_USER\Software\Classes\.com] >> %P%
regedit.exe %P%
del %P%
download here
Start RstRegistryFix and click Yes for all security questions (1 on Windows XP, 2 questions on Vista). Then reboot.

Details: Restorator creates registry entries in order to associate itself with the file extension and/or for the right-click context menu in the explorer. Now if run with limited access rights ("Limited Account" on 2000/XP, default accounts on Vista), Restorator will not have access to the system-wide registry keys for context menu management (e.g. HKEY_CLASSES_ROOT\.exe) but it will use a user-only area of the registry for enabling its extension, e.g. HKEY_CURRENT_USER\Software\Classes\.exe). Because that area is usually empty, it will create the usual keys for context menu association. That will, however, be mapped to the system wide keys, and therefore de facto overwrite the existing keys in HKEY_CLASSES_ROOT.
Now Restorator is fixed to always check if there are values in HKEY_CLASSES_ROOT before writing to the user-only area in HKEY_CURRENT_USER.

We're very sorry for this inconvenience. This problem is fixed with Restorator 2007 Update 2.

The Bome Software team


2007-07-17 21:43:37

Yes I’ve the same problem, two days before after an installation of Restorator 2007, my XP stop to recognize all exe files. Hopefully I manage to fix the problem, but you are right the problem exist.


2007-07-19 15:41:28


I have been trying out a copy of Restorator 2006 on Vista. Now I guess that this is not Vista ready but it might provide a clue to you.

The problems started when I tried to load a File (via File/Open) I got some error message which I believe mentioned something like ??vregister.dll?? - I don't remember exactly. The file did not load. I tried a second time (via File/Open) - nothing happened. I then tried dragging/dropping a file. This worked and the program displayed all the resources.

I then found I couldn't run any of the files in the Start menu. I guess the .exe association had gone.
Upon reboot, only some apps loaded at Startup. Many were missing. So for example Gadgets never loaded. My Virus program never loaded. And I still couldn't run any program in the Start menu. I didn't get any messages about File Associations.

I got back on track by a System Restore.

It seems to me that the file association is lost during the File/Open activity.


2007-07-19 17:29:08

THanks for the report. We have tried many times on fresh Windows and Vista installs, and we could not reproduce this behavior. We'll try to follow exactly your steps.
Really helpful would be the info from the registry, as explained above...



2007-07-19 18:07:27

Hi florian

It wasn't until I checked this Forum that I found out that the problem was actually the loss of a File Association which is not that difficult to fix. However, just in case there are other problems that we are all unaware of, I will not be repeating the test.
Actually I found that the experience did me a small favour. System Restore had apparently not been working for about 2 months! Fortunately I have hardly added anything to the original so a 2 month Restore was OK

I hope you succeed in tracking the bug down !


2007-07-19 18:54:20

yes, I can understand that you have no interest in trying to reproduce this problem. I'm glad that you've had a not-too-annoying way for restoring your system. I'd be very happy if I could track this down...



2007-07-29 14:03:46

We got this fixed, see the first message. Thanks everybody for reporting.